Архив форума Ace Stream       Wiki        Info

перейти на новый форум
Расширенный поиск  

Автор Тема: Тестируем ПО Ace Stream в snap пакете.  (Прочитано 104877 раз)

0 Пользователей и 1 Гость смотрят эту тему.

akelgurrr

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 3
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #120 : 09 Декабря 2019, 13:20:17 »

apt-cache policy snapd
snapd:
  Installed: 2.37.4-1+b1
  Candidate: 2.37.4-1+b1
  Version table:
 *** 2.37.4-1+b1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

snap list | grep core
core18           20191126      1279  stable    canonical*  base
Записан

vasilisc

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 48
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #121 : 10 Декабря 2019, 06:56:54 »

snap list | grep core
core18           20191126      1279  stable    canonical*  base
всё верно =( и странно что есть какие-то проблемы. Я поставил в виртуальной среде "вчистую" Дебиан 10 и у меня нет проблем.
дайте вывод
snap connections | grep -E "(ace|audio)"

могу порекомендовать
apt update
apt upgrade
snap refresh
snap remove acestreamplayer
snap install acestreamplayer
« Последнее редактирование: 10 Декабря 2019, 07:14:23 от vasilisc »
Записан

akelgurrr

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 3
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #122 : 10 Декабря 2019, 11:51:18 »

Здравствуйте, vasilisc! В первую очередь хотелось бы сказать вам спасибо, за помощь и затраченное время в решение моей проблемы!  Всё-таки разобрался в чём проблема. Проблема в apparmor.

Failed to start Load AppArmor profles
Error: No profiles found in var/lib/snapd/apparmor/profiles

Проблему пока не решил, на виртуалке потестирую всякие решения из гугла. Напишу сюда, если решу эту проблему. Кто знает - может я не один такой!

Без Acestreamа не остался, smplayer подружил  с движком  консольным 3.1.49  :)
Записан

vasilisc

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 48
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #123 : 10 Декабря 2019, 14:37:33 »

Проблема в apparmor.

Failed to start Load AppArmor profles
Error: No profiles found in var/lib/snapd/apparmor/profiles

Проблему пока не решил
программы в пакете snap работают под присмотром AppArmor и в этом суть технологии (самодостаточность + безопасность)
как вариант вы можете установить программу в режиме classic (дескать понимаете что вы делаете)
snap install --classic acestreamplayer
программа не будет ограничиваться системой мандатного доступа AppArmor
Записан

redkino

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 1
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #124 : 07 Января 2020, 01:14:52 »

Здравствуйте, vasilisc!

Флаг --classic на Debian 10 не помогает.
При установке флаг просто игнорируется,
о чём появляется сообщение при установке acestream.

Зато помогает флаг --devmode:
snap install acestreamplayer --devmode

Спасибо за труды. С уважением Евгений.
Записан

sir

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 1
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #125 : 25 Января 2020, 12:00:45 »

После переустановки дебиана 10 перестал запускаться AceStream как движок, так и плееры.
Ставил с нуля через  sudo snap install acestreamplayer.
Уже тогда обратил на сообщение  - INFO snap "acestreamplayer" has bad plugs or slots: (unknown interface "audio-playback")

Добрый день.
У меня точно такая же проблема.
При установке ошибка " INFO has bad plugs or slots:audio-playback (unknown interface "audio-playback")"
Только изначально ярлыки acestream появлялись в меню, то сейчас, после очередной переустановки, уже нет.
Ради интереса попробовал на другом ноуте - аналогично.

upd:
На одном ноуте, хоть и с ошибками, но все же завелась командой
snap run acestreamplayer.engine

На втором не запускается, ни ярлыком ни командой.
« Последнее редактирование: 27 Января 2020, 09:33:25 от sir »
Записан

torsini

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 1
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #126 : 09 Февраля 2020, 22:09:27 »

Такая же проблема при установке через snap на Ubuntu 16.10.

Engine (3.1.49) run with options: --client-gtk
Gtk-Message: 23:04:44.978: Failed to load module "overlay-scrollbar"
Gtk-Message: 23:04:44.978: Failed to load module "gail"
Gtk-Message: 23:04:44.978: Failed to load module "atk-bridge"
sh: 1: /bin/netstat: not found
sh: 1: /sbin/ifconfig: not found
/snap/acestreamplayer/10/bin/run.sh: line 641: /bin/nc: Permission denied
И дальше "/snap/acestreamplayer/10/bin/run.sh: line 641: /bin/nc: Permission denied" бесконечно повторяется.
Записан

vasilisc

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 48
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #127 : 29 Февраля 2020, 15:06:39 »

Такая же проблема при установке через snap на Ubuntu 16.10.

Engine (3.1.49) run with options: --client-gtk
Gtk-Message: 23:04:44.978: Failed to load module "overlay-scrollbar"
Gtk-Message: 23:04:44.978: Failed to load module "gail"
Gtk-Message: 23:04:44.978: Failed to load module "atk-bridge"
sh: 1: /bin/netstat: not found
sh: 1: /sbin/ifconfig: not found
/snap/acestreamplayer/10/bin/run.sh: line 641: /bin/nc: Permission denied
И дальше "/snap/acestreamplayer/10/bin/run.sh: line 641: /bin/nc: Permission denied" бесконечно повторяется.
К сожалению, мне вам не помочь. Обычный релиз Ubuntu 16.10 уже закончил свой жизненный цикл и у него End of Life. Мне даже не скачать образ с официального сайта. Попробуйте обновиться до ближайшего LTS релиза Ubuntu 18.04. Возможно поможет. Как вариант, удалите пакет acestreamplayer и поставьте в режиме devmode, отключив безопасность
sudo snap remove acestreamplayer
sudo snap install acestreamplayer --devmode
« Последнее редактирование: 29 Февраля 2020, 15:11:10 от vasilisc »
Записан

vasilisc

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 48
Re: Тестируем ПО Ace Stream в snap пакете.
« Ответ #128 : 03 Марта 2020, 07:21:04 »

Процитирую переписку по email где проблема была решена так

> Проблема решилась установкой snap-пакета core в дополнение к core18:
> 'sudo snap install core'. Вероятно, он должен быть в зависимостях
> acestreamplayer?

Так таковых зависимостей (dependency) в мире snap нет ... есть connect между снапами, если программа сложна и разнесена по различным снапам. core - это минималистичный снап пакет олицетворение самой системы .. она ставится автоматом при начале работы snapd демона. Почему у вас были проблемы с core18 я к сожалению не знаю, но запомню ваш совет-решение и буду советовать его другим при проблемах. Спасибо за отклик и решение проблемы.
Записан